官方QQ群收藏本站

百问linux嵌入式论坛

 找回密码
 立即注册

QQ登录

只需一步,快速开始

查看: 1633|回复: 5

【已解决】单板上用insmod first_drv.ko加载成功,但用cat /proc/devices查看时...

[复制链接]

4

主题

7

帖子

32

积分

新手上路

Rank: 1

积分
32
发表于 2014-8-6 20:37:27 | 显示全部楼层 |阅读模式
本帖最后由 st_100ask 于 2014-8-7 16:11 编辑

根据第一期视频12课第2节,单板加载驱动后,查看不到驱动ID号,请指点,问题会在哪?单板内核原来不带此驱动(重新上电后,我用RMMOD卸载不成功)。

first_drv.c

1.09 KB, 下载次数: 563

first_drv.ko

46.26 KB, 下载次数: 1143

Makefile

179 Bytes, 下载次数: 1081

回复

使用道具 举报

189

主题

1760

帖子

6145

积分

超级版主

答疑助手

Rank: 8Rank: 8

积分
6145
QQ
发表于 2014-8-6 22:20:03 | 显示全部楼层
这个问题非常普遍
我没看你的代码,如果代码完全和老师一样,

原因: 板子用的uImage不是first_drv用的LINUX源码,不明白也没关系,照做就行

1, 重新编译内核,并用新编译好的uImage启动板子
2, 重新编译驱动
3, 再insmod
新手如何向我们反馈有效的信息,以便解决问题,见此贴:
http://www.100ask.org/bbs/forum. ... id=10914&extra=
回复 支持 反对

使用道具 举报

4

主题

7

帖子

32

积分

新手上路

Rank: 1

积分
32
 楼主| 发表于 2014-8-7 14:06:59 | 显示全部楼层
问题解决,如2楼说的一样
回复 支持 反对

使用道具 举报

189

主题

1760

帖子

6145

积分

超级版主

答疑助手

Rank: 8Rank: 8

积分
6145
QQ
发表于 2014-8-7 14:19:07 | 显示全部楼层
2014 发表于 2014-8-7 14:06
问题解决,如2楼说的一样

反馈较及时,这样的态度,斑竹 不解答都难纳
新手如何向我们反馈有效的信息,以便解决问题,见此贴:
http://www.100ask.org/bbs/forum. ... id=10914&extra=
回复 支持 反对

使用道具 举报

0

主题

1

帖子

40

积分

新手上路

Rank: 1

积分
40
发表于 2019-5-17 14:20:09 | 显示全部楼层
很感谢 重新编译你内核 生成uImage 可以解决
回复 支持 反对

使用道具 举报

技术支持
在线咨询
咨询热线
0755-86200561
微信扫一扫
获取更多资讯!

Archiver|小黑屋|百问linux嵌入式论坛     

GMT+8, 2019-10-17 14:05 , Processed in 0.071549 second(s), 10 queries , File On.

Powered by Discuz! X3.3 Licensed

© 2001-2017 Comsenz Inc. Template By 【未来科技】【 www.wekei.cn 】

快速回复 返回顶部 返回列表